MPM-install trouble

Dear Dr Krishna Kumar,

I installed CB-GEO mpm in my PC (Ubuntu Ubuntu 18.04.3 LTS onto the Virtual box 6.0.

The cmake command and error messages are follows

`mkdir build && cd build && cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_COMPILER=g++ /home/nanopore/mpm

– Looking for IceConnectionNumber in ICE
– Looking for IceConnectionNumber in ICE - found
– Found OpenGL: /usr/lib/x86_64-linux-gnu/libOpenGL.so found components: OpenGL GLX
– Checking for package ‘KaHIP’
CMake Error at /usr/local/share/cmake-3.12/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
KaHIP could not be found/configured. (missing: KAHIP_LIBRARIES
KAHIP_INCLUDE_DIRS KAHIP_TEST_RUNS)
Call Stack (most recent call first):
/usr/local/share/cmake-3.12/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
cmake/FindKaHIP.cmake:140 (find_package_handle_standard_args)
CMakeLists.txt:106 (find_package)

– Configuring incomplete, errors occurred!
See also “/home/nanopore/mpm/build/CMakeFiles/CMakeOutput.log”.

I already installed the KaHIP with the following command.

cd ~/workspace/ && git clone https://github.com/schulzchristian/KaHIP &&
cd KaHIP && sh ./compile_withcmake.sh

What should I do to solve this problem?
Thank you for your kind support!
Teddy

Could you please check the version of cmake by cmake --version.

You need to pass the KaHIP_DIR as a CMake argument, when you are in the mpm/build directory please do: export CXX_COMPILER=mpicxx && cmake -DCMAKE_BUILD_TYPE=Release -DKAHIP_ROOT=~/workspace/KaHIP/ ..

Please check: https://github.com/cb-geo/mpm#compile-with-mpi-running-on-a-cluster

Thanks Dr.Krishna

I checked my conditions,
The cmake version is 3.16.2
And, current error as follows
getech@getech-VirtualBox:~/mpm/build$ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_COMPILER=g++ /home/getech/mpm
– HDF5: Using hdf5 compiler wrapper to determine CXX configuration
– Could NOT find MKL (missing: MKL_INCLUDE_DIR MKL_LIBRARIES)
– Checking for package ‘KaHIP’
– Could NOT find VTK (missing: VTK_DIR)
– Checking for package ‘Partio’
– Partio could not be found/configured. (missing: PARTIO_LIBRARIES PARTIO_INCLUDE_DIRS)
– Configuring done
– Generating done
– Build files have been written to: /home/getech/mpm/build
I will try to install again.

Hi @Teddy-H, You can run without KaHIP. Looks like the configuration is complete. So please do make that will generate mpm and mpmtest

Dear kks32,
I can install the CB-GEP MPM without KaHIP with your special assistant.
And I tried to run the benchmark with 3D Dam break.

At that time, It could not proceed with 9479/2000 steps with the following message.


MPM main: Particle outside the mesh domain

MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.


This error occurred from my machine or setup conditions?
My machine condition is Core i7 8th gen and 40GM memory.

Please tell me your comments.

Hi @Teddy-H, Thanks for bringing this up. I also get the same error for that problem. Could you try the 3D hydrostatic column benchmark. I’ll look into this issue.