CMake Error VTK not found in TACC LoneStar5

Using develop branch from cb-geo, vtk is not found in TACC. It might be due to the last change in CMakeLists.txt to solve issue with Ubuntu 18.04.

login1.ls5(1010)$ mkdir build && cd build && cmake -DBOOST_ROOT=$TACC_BOOST_DIR -DBOOST_INCLUDE_DIRS=$TACC_BOOST_INC -DCMAKE_BUILD_TYPE=Release -DEIGEN3_INCLUDE_DIR=$HOME/eigen ..
-- The CXX compiler identification is GNU 6.3.0
-- Check for working CXX compiler: /opt/apps/gcc/6.3.0/bin/c++
-- Check for working CXX compiler: /opt/apps/gcc/6.3.0/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Boost version: 1.64.0
-- Found the following Boost libraries:
--   filesystem
--   system
-- Found MPI_CXX: /usr/lib64/libdl.so (found version "3.1") 
-- Found MPI: TRUE (found version "3.1")  
-- The C compiler identification is GNU 6.3.0
-- Check for working C compiler: /opt/apps/gcc/6.3.0/bin/gcc
-- Check for working C compiler: /opt/apps/gcc/6.3.0/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- HDF5: Using hdf5 compiler wrapper to determine CXX configuration
-- Found HDF5: /opt/apps/intel18/hdf5/1.8.21/x86_64/lib/libhdf5_cpp.so;/opt/apps/intel18/hdf5/1.8.21/x86_64/lib/libhdf5.so;/opt/apps/intel18/hdf5/1.8.21/x86_64/lib/libsz.so;/usr/lib64/libz.so;/usr/lib64/libdl.so;/usr/lib64/libm.so (found version "1.8.21") found components:  CXX HL 
-- Found OpenMP_C: -fopenmp (found version "4.5") 
-- Found OpenMP_CXX: -fopenmp (found version "4.5") 
-- Found OpenMP: TRUE (found version "4.5")  
-- Found TBB: /opt/intel/compilers_and_libraries_2018.2.199/linux/tbb/include (found version "2018.0")  
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - found
-- Found Threads: TRUE  
-- Could NOT find VTK (missing: VTK_DIR)
-- Configuring done
-- Generating done
-- Build files have been written to: /work/06372/ezrayst/cb-geo/mpm/build

It works when I do the following: https://github.com/cb-geo/mpm/pull/474

Could you share the list of modules loaded using module ls

Issue solved when vtk is loaded.

login1.ls5(1051)$ module ls

Currently Loaded Modules:
  1) intel/18.0.2       5) cmake/3.12.3     9) boost/1.64   13) vtk/8.2.0
  2) cray_mpich/7.7.3   6) xalt/2.7.3      10) hdf5/1.8.21
  3) git/2.19.1         7) TACC/1.0        11) swr/18.3.3
  4) autotools/1.2      8) python2/2.7.15  12) qt5/5.11.2